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Introduction

Scope of this document

This document provides guidelines on how BRAHMS is used to produce monographic outputs 
for the Species Plantarum Project. The principles applied here can be adapted for different flora 
or monograph series, for example the Kew Bulletin and the Journal of the Linnean Society. 

The  aim  of  the  workshop  sections  is  to  get  you  started  with  monograph  production.  The 
workshops review the following activities:

• The installation of the BRAHMS software and the pre-configured template database 
provided for the Species Plantarum Project. 

• The assembly of species and specimen data using Rapid Data Entry.
• The editing and refinement of these data within BRAHMS.
• The production of outputs and the transfer of these outputs to your word processor for 

final editing and monograph production.

Speed up and standardize

The objectives of using BRAHMS with the Species Plantarum Project are to  speed up and 
standardize monograph  production.  The  pre-configured  Species  Plantarum  database  is 
provided together with or with access to:

• Reference files of taxa, authors, botanical publications and geographic (TDWG) files.
• Base maps for map production (all countries) in SHP format for use with DIVA or Arc 

View.
• BRAHMS Rapid Data Entry file templates for species and specimen data entry.
• Reporting templates to produce the required SPP monographic outputs.

RDE vs. BRAHMS

Although data can be entered directly into a BRAHMS database, the use of the RDE method is 
recommended when new data are being added. RDE, an acronym for Rapid Data Entry, is a 
module  of  BRAHMS  optimized  for  data  entry  efficiency.  It  can  be  used  to  enter  different 
categories  of  data  including  the  taxonomic  names  and  specimens  as  discussed  in  this 
document.  The  full  functionality  of  RDE is  described  under  Documentation > Rapid Data 
Entry. Using RDE, data may be:

• Typed in from scratch.
• Transferred from other formats using the BRAHMS Import Wizard.
• In special cases, imported form web site downloads, for example IPNI.
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SPP database

RDE files are auto-
checked and 
transferred into your  
database.

The structure of RDE files for taxa or specimens can be edited rather like  
Excel worksheets. The SPP project database is delivered with pre-formatted 
RDE file templates for taxonomic names and specimen data.

Within the database, data can be 
freely edited, queried and used to 
produce the required SPP outputs.



RDE has a host of functions to assist with the optimization of data entry. Monographers can 
benefit by downloading data from relevant websites including IPNI and incorporating these data 
directly into RDE files.

Data already added into different formats, for example data held in Excel and Access files, can be 
transferred into RDE format using the BRAHMS Import Wizard.

Editing data within BRAHMS

Data added directly to BRAHMS or transferred from RDE files can subsequently be edited. All of 
the  data  entry  and  editing  tasks  performed  in  RDE can  be  undertaken  in  BRAHMS itself. 
Typically, the monographer will use RDE to assemble as much data as possible, transfer these 
data into BRAHMS and then edit the data, gradually refining the database to the required level.  
At data stage more data can be added or data can be completely deleted.

Typical editing activities often performed inside BRAHMS rather than in RDE are the linking up 
of synonyms and type specimens, the addition of mapping references for specimens, the further  
entry of smaller numbers of species and specimen records and the general correction of data 
initially entered in RDE. 

Editing geographic data and mapping references in the main collection file.
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Descriptive text and other facts can be added to families, genera and species. 

Producing formatted outputs and maps

The task  of  assembling  large  amounts  of  data  from specimens  and  bibliographic  sources, 
editing these data, and preparing complex outputs including checklists, taxonomic treatments,  
specimen lists, maps and indexes, is a daunting and time consuming one for the researcher  
embarking on a new work. Using the appropriate database methods, the preparation of outputs 
such as those required for the Species Plantarum Project can be speeded up. 

Data stored in BRAHMS can be assembled from all corners of your database and formatted 
to create an almost limitless range of checklist styles, monograph-related outputs, maps and 
indexes. Such outputs, although they have a different emphasis, are produced in a similar way. 
Reporting flexibility is restricted only by the data that have been entered into the database, not  
by the order the data were entered in or the original purpose they were entered for. 

As  explained  in  the  main  documentation,  BRAHMS  Text  Reporting provides  you  with  the 
ultimate control over your data and is used to produce more complex outputs including checklist 
and monograph outputs. 
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Screen showing a section of a generated report for the genus Marsippospermum in the Juncaceae. This 
part of the report includes the accepted taxon name with taxonomic treatment, details of illustrations and  
maps, text description, distribution and ecology summary followed by a list of cited specimens, all  
components formatted to SPP standard using a BRAHMS Text Report.

Many botanists find it difficult to produce simple black and white species distribution maps, often finding it  
necessary to seek help from GIS specialists. Assuming the necessary latitude and longitude points have 
been added to your specimen records, the production of maps for any geographical area is facilitated 
through the BRAHMS DIVA-GIS link. Base map data are available on the BRAHMS website.
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Flexibility

Aside from adhering to the formatting requirements of the Species Plantarum Project, 
different botanists will have their own specific data storage and reporting preferences and 
needs. You are not restricted to the data entry templates and reporting procedures reviewed 
here – rather, these are provided for guidance in the context of the Species Plantarum Project. 
For example, if you want to add additional fields for your specimens or species descriptions, you 
can do so. In the same way, you can add new reporting and map formats as needed.

Help and documentation links

Throughout this document, reference is made to the BRAHMS help document. An example from 
the text is ‘Full details about backing up are provided under Documentation > Database 
maintenance > Backing up.’ This refers to the Documentation menu on the 
www.brahmsonline.com website – the direct link is 
http://herbaria.plants.ox.ac.uk/BOL/documentation/default.aspx. 

Alternatively, a searchable help file can be downloaded from 
http://herbaria.plants.ox.ac.uk/BOL/documentation/helpchm.aspx.

The 50+ exercises provided at the end of the BRAHMS help file illustrate some of this flexibility.

BRAHMS documentation is extensive and is available to consult online or download as a searchable 
Windows CHM help file.
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Workshop 1 – installations

Installation of BRAHMS software

• Go to the BRAHMS software download page on 
http://herbaria.plants.ox.ac.uk/BOL/software/default.aspx

• Choose the Download BRAHMS option and save the single download file to your 
desktop (or any temporary folder). Run the setup file to install BRAHMS following the 
default settings. You can modify these if necessary.

• Registered users can login to and download an activation key. New users should 
register first. For help go to Documentation > Installation and upgrading > System 
installation > Activation keys.

Installation of the Species Plantarum template database

The SPP template database is an empty database that has been pre-configured for the Species 
Plantarum Project.  It  includes no taxa or  specimen data.  It  does however  include RDE file 
templates for data entry, useful reference files for taxa, authors and publication journals, the 
essential additional fields you need for species descriptions and the required report templates.

• Go to the BRAHMS Resources page on 
http://herbaria.plants.ox.ac.uk/BOL/resources/default.aspx

• Click on the Species Plantarum Project resource entry and download this to your 
desktop (or any temporary folder).

• Expand this zip file to C: (or another drive). This will create a folder called 
C:\brahmsdata-spp with various subfolders. 

Installation of DIVA-GIS for mapping

If you want to produce species distribution maps from BRAHMS based on the specimens yet 
have no existing mapping software, we recommend that you install the free mapping system 
DIVA-GIS. If you already have mapping software (e.g. Arc View), you can use this.

• To install DIVA, download the single DIVA setup file (full installation) from 
http://www.diva-gis.org/down.asp to any temporary directory.

• Expand the downloaded zip file into the same temporary directory and then run the 
setup.exe file.
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database together with the 
required data entry and 
reporting templates can be 
downloaded and installed, 
ready to link to your 
BRAHMS software.
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Download base map files

If you are planning to make maps, you should download some handy global base maps for a) 
countries and b) internal country boundaries – both for use with DIVA. As it happens, DIVA uses 
standard SHP files (as used by Arc View). 

• Go to the BRAHMS website Resources page on 
http://herbaria.plants.ox.ac.uk/BOL/resources/default.aspx

• Download the zip mapping file Country borders to the \brahmsdata-
spp\mapping\basemaps folder. Expand the zip file to the same folder. You can then 
delete the zip download.

• Repeat this procedure for the internal country administrative regions file, also provided 
on the Resources page.

These base map files are now ready to open with DIVA when you reach the mapping stage later 
on.

Workshop 2 – initial setup

Login to BRAHMS

• Log into BRAHMS as user Admin using the default password A. Initially, choose the 
Template database. This empty database is included in the software download.

Note: if your BRAHMS setup did not automatically create a desktop shortcut, locate the  
BRAHMS.EXE program file in the default installation folder which would be \Program  
files\Brahms.

BRAHMS login screen selecting the Template database

Register the Species Plantarum database

• You need to connect the BRAHMS software to the SPP database by registering this 
pre-configured database in the database manager file. To do this, select File > 
Database manager. 

• The database can be linked manually using the Add option. However, the quickest way 
is to now select Tools > Add sample databases > Species Plantarum Project. This 
action will register the SPP database in the BRAHMS database manager.
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The database manager showing the registered Species Plantarum Project. The Template database is  
always present and is used to create new databases. In this screen, the Leucaena database, used 
throughout the BRAHMS training exercises, is also registered in the manager. 

Log into SPP database – adding user name details

• Having successfully registered the SPP database,  log out of BRAHMS and then  re-
login but this time choosing the SPP database from the project list provided on the log 
in screen.

Although you can continue to work as user Admin, we recommend that as a first step, you own 
user name and password. To do this:

• Select Admin > System access and passwords > Users and passwords. 
• Click on the Add toolbar button. Add you name (e.g. ‘John Smith’) and password (e.g.  

‘JS’) in the boxes provided. All other fields can be left with their default settings.
• You can now exit BRAHMS and once more, login but this time, select your newly added 

user name on the login screen, again choosing the SPP project.

Also note that assuming you have a desktop shortcut to BRAHMS.EXE, you can add your user 
name after the BRAHMS.EXE target as in the image below. When you login in, your user name 
is selected by default. The help file includes procedures.

After setting up a desktop shortcut, adding your user name after the Target file (BRAHMS.EXE) speeds up 
the login process.

Check system settings

Most setup options can be edited using the  Admin > Project configuration. After you have 
used BRAHMS fore a while, you may want to explore these options more fully, for example,  
opting to change some Data Grid features.
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One useful option to set at the start is your Home Herbarium code – assuming you have one. To 
do this, select Admin > Project configuration > General and enter the code (e.g. OXF) in the 
box provided.

Check mapping settings

If necessary, you can edit the map configuration settings using the Admin > Project 
configuration > maps screen.

The SPP template database is pre-configured to set DIVA as the default mapping system and to 
locate DIVA.EXE in the default install location which is c:\program files\diva-gis\diva.exe. 

By default, BRAHMS will expect latitude/longitude values to be entered in degree minutes 
seconds (DMS) format. If necessary, you can change this using the option provided on the 
MAPS configuration page. Map data storage is discussed in detail under Documentation > 
Mapping.

Some notes on database maintenance

It is best to be confident about database maintenance from the outset. Two issues are 
discussed here – backing up and re-indexing your database.

To back up, assuming all your various project data files are stored within the \Brahmsdata-spp 
folder (with its various sub-directories), all you have to do is to make a copy of this entire folder. 
We recommend you archive (or zip) files before backing up as this saves space and time. Copy 
the backed up files to a safe place on a networked drive or another disk. Full details about 
backing up are provided under Documentation > Database maintenance > Backing up.

Re-indexing checks over your database, removing records deleted since the last re-index and 
recreates al the index files associated with the various database files. Periodic re-indexing, 
while not essential (indexes are automatically kept up to date) can improve database 
performance. To re-index the opened database, select Admin > Database maintenance > Re-
index and pack data files.

Workshop 3 – Entering taxa using RDE

Introduction

Ideally, you will start your project by preparing a list of names for your taxonomic group. It is  
usually better to do this (or some of it) before the specimen entry phase as it is very convenient 
to be able to consult your names list when adding specimens. Having said this, projects do often 
start with specimen entry or make a start with the assembly of specimen and taxon name data 
at the same time.

Creating a taxon RDE file

The  SPP  database  is  provided  with  a  template  RDE  file  for  taxa  named  spp-taxa-
rdetemplate.dbf. Rather than entering data into the template (you can do this), it  is best to  
make a copy of  the taxon template and enter  data  here.  You may end up making several  
separate taxon RDE files, with the same or with different structures. 

As a first step, you will copy this file in the RDE file manager.
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• Select  Taxa > Add/edit data using Rapid Data Entry files. This opens the RDE file 
manager for taxa. You will see the file spp-taxa-rdetemplate.dbf is already registered 
in the manager.

• Click once on the record that includes the RDE template file to select that record. 
• Select File > Create a blank data file > Create an empty file from the current RDE 

file.
• When you do this, the template is copied and then registered in your RDE taxon file  

manager. To open the RDE file, dbl-click on the file name.

For an explanation of the various fields in the file, click on the   toolbar. Some fields (e.g. 
DESCRIP and DISTRIB) may not be represented in help list as these are what we call ‘non-
standard’ BRAHMS fields. Non-standard fields are user defined fields and you can add as many 
of these as you like. Non-standard fields are described in the help section Documentation > 
Rapid Data Entry > RDE files > Standard and non-standard fields.
 

Changing the file structure

One of the advantages of using RDE files is that you can freely change their structure by adding 
or removing fields – or changing the field order. For example, the template SPP file includes the 
fields INV and LEGITIMACY, both explained in the  toolbar help. You may decide to exclude 
these fields from the RDE file either because you don’t want to enter these facts about your 
taxon names or because you consider that this information can be edited in later on, directly into  
BRAHMS. Similarly, you may not need the fields RANK2, SP3 and AUTHOR3. Remove these 
fields as appropriate.

• To remove unwanted fields (or make any other changes), with the RDE file opened, 
select File > Modify file structure …. 

A full description of this function is available in the documentation under System fundamentals 
> Rapid Data Entry > RDE files > Modifying file structure. These procedures apply equally to 
specimen RDE files.

Getting started with data entry

In  the  opened  file,  you  can  type  freely  data  into  the  respective  fields.  Fields  can  be  left 
completely blank if you have not data. Data are saved automatically when a file is closed – there 
is no special save function. 

To add blank records, use the Add toolbar   or enter  Alt+A.  The chances are you will  be 
working in one family or perhaps even a single  genus.  Thus the values in these fields will  
change rarely. After you have added a new record, you can press the  F4 key to copy a field 
from the previous record – or use Ctrl+F4 to copy an entire record.

Because, at this stage, your actual database is empty, you can’t yet make use of most lookup 
and AutoComplete functions- this will change as your database matures. 

The characteristics of the data grid you are working in can be changed using the set up options  
provided under  Admin > Project configuration > Data grids. Typical examples are whether 
you want to highlight the current record and whether or not you wish text to be ‘selected’ (black) 
when you move into a field.

Also note the TAG and DEL columns at the start of the file. The fields are found in all BRAHMS 
files allowing to select (tag) and mark records for deletion respectively. You can read up on 
these functions in the documentation under  System fundamentals > Tagging  and  System 
fundamentals > Editing data > Deleting records. Thus, to tag a record, click on the  toolbar 
(again  to  remove  tag).  To  highlight  all  tagged  records,  select  Tag  >  Highlight  tagged  > 
Highlighting ON.
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Although the SPP database is initially empty, some external reference files have been included 
with the project, notably for family, genus and author names and botanical publications. Using 
Shift+F9 in the FAMILY, GENUS, any of the AUTHOR fields or the JOURNAL field will open up  
a searchable list of names to select from.

You can open and edit the external taxa reference files using Taxa > External reference files. 
In the case of the family/genus file, you can use a Tools option to switch family names between 
Compositae/Asteraceae etc. The external botanical publications file can be opened using Biblio 
> External reference files.

Checking names online

If you are online, you can use the internet toolbar on the right of the screen to consult useful 
websites like  IPNI,  Kew’s  Electronic  Plant  Information  Centre,  TROPICOS and others.  The 
toolbar options detect what name has been typed into the RDE file and then try to locate that 
name. In some cases the options are also field sensitive. Thus is the cursor is in the FAMILY 
field and you click on the IPNI toolbar, a search is made on that family.

At this stage, in the RDE file, you may choose to enter all the details you have available on your 
taxa including text descriptions and even synonym links (see below for more on synonyms). On 
the other hand, you may enter only the essential details of the names and decide to edit the 
data after the RDE file has been transferred to BRAHMS.

A description of the main RDE fields for taxa

TAG Used for selecting records
DEL Mark a record for deletion
RDECODE A unique numeric code required if using the SYNOF 

field in RDE
SYNOF Numeric code pointing to the same number in 

RDECODE
TAXSTAT Taxonomic status of name e.g. ‘acc’ for accepted 

name
FAMILY Name of family
GENUS Name of genus
SP1 First specific epithet
AUTHOR1 Author name for SP1
UNIQUE A numeric code only need if 2 or more identical names 

are entered.
RANK1 Rank of SP2, e.g. ssp. Or var.
SP2 Second specific epithet
AUTHOR2 Author name for SP2
JOURNAL Journal abbreviation name of protologue
VOLUME / PART Volume for protologue
PAGESTART/PAGEEND Page(s) of protologue
YEAR Year of publication
SYNNOTE Notes about synonymy
TYPENOTE Notes about type
NOMNOTE Other nomenclatural notes
MONOCODE Monograph code
IPNI IPNI reference
DESCRIP Species description
TDWG TDWG distribution summary
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Editing memo fields for descriptions and other notes

Memo fields are used to store variable amounts of text, ideal for descriptions. Memo fields are 
described in full in the help section Documentation > System Fundamentals > Memo fields. 
To open a memo field, you can dbl-click on the memo or enter Ctrl+M when the cursor is on it.  
In the SPP taxon RDE file, there are several memo fields which can be edited as appropriate.

Transfer the Taxon RDE file into BRAHMS

You can transfer an RDE file into BRAHMS at any stage. After doing so, you would normally 
keep the file as a back-up. Although it is possible to edit the original RDE file are transfer the 
edits into BRAHMS, after the transfer, it is usually easier to undertake editing inside BRAHMS. 
You may subsequently open, edit and transfer several more taxon RDE files rather than add all  
your data to one RDE file.

• To execute the RDE file transfer, close the file and select the  toolbar option. When 
prompted, ‘Restrict to Tagged?’, respond ‘No’ – unless you wish to selectively import 
tagged records.

The RDE transfer screen. Note that the screen is indicating that there are 2 non-standard fields. These are  
the DESCRIP and TDWG memo fields. As these fields are available in the species linked data file, they  
will be stored in the database.
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• Click on the Transfer to BRAHMS button to proceed.
• To check these names have been safely stored in BRAHMS, select Taxa > View edit 

species in database.

Workshop 4 – entering specimen data using RDE

Creating a specimen RDE file

The procedures for entering specimen data using RDE are broadly the same as those for taxa – 
although there are more fields to consider.

The SPP database is provided with a template RDE file for specimens named spp-specimens-
rdetemplate.dbf. Rather than entering data into the template (you can do this), it  is best to  
make a copy of the specimen template and enter data here. You may end up making several  
separate specimen RDE files, with the same or with different structures. 

As a first step, you will copy this file in the RDE file manager.

• Select Collections > Add/edit data using Rapid Data Entry files. This opens the 
RDE file manager for collections. You will see the file spp-specimens-rdetemplate.dbf 
is already registered in the manager.

• Click once on the record that includes the RDE template file to select that record. 
• Select File > Create a blank data file > Create an empty file from the current RDE 

file.
• When you do this, the template is copied and then registered in your RDE collection file 

manager. To open the RDE file, dbl-click on the file name.

For an explanation of the various fields in the file, click on the  toolbar. As with the taxon RDE 
file, any non-standard fields will not be represented in help list.

Changing the file structure

As described for the taxon RDE above, you can add or remove fields using File > Modify file 
structure …. The scope to add ands remove fields in specimen RDE files is greater than with  
taxa – as there are many more potential fields describing specimens.

Entering specimen data

Above is a typical example of a specimen RDE file showing some of the main fields. To speed up typing,  
use the function key F4 to copy a field from above or Ctrl+F4 to copy an entire record. Numerous further  
copy and lookup settings can be configured and are described in the documentation.
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A description of the main RDE fields for specimens

TAG Used for selecting records
DEL Mark a record for deletion
COLLECTOR Name of collector
PREFIX Prefix for collection field number
NUMBER Collection field number
SUFFIX Suffix for collection field number
DUPS Known duplicates
FAMILY Family name
GENUS Genus name
SP1 First specific epithet
RANK1 Rank of SP2, e.g. ssp. Or var.
SP2 Second specific epithet
COUNTRY Country of collection
MAJORAREA Major country area
MINORAREA Minor country area
GAZETTEER Name of nearest place
LAT Latitude
NS N or S
LONG Longitude
EW E or W

Collector name formats

Although it is better to initially enter collector names in the format Surname + Initials as in ‘Smith  
A.B.’, it may be a requirement that collector names are later cited in a different format, e.g. ‘A.B. 
Smith’.  Within BRAHMS, all  collector names can be assigned different formats for reporting 
purposes. 

To  edit  the  list  of  collector  names  and  optionally  provide  a  different  print  format,  select  
Collections > Collector and detby names. Edit  your alternative names into the alternative 
name column(s) provided. Further information is provided under  Documentation > Data in 
BRAHMS > Collector names > Using alternative collector names. Alternative names can be 
included in reports (e.g. specimen citation lists) by default.

Entering map references

Specimen latitude and longitude are entered into the LAT and LONG numeric fields as available 
in RDE and in BRAHMS. The Species Plantarum template database is configured by default to 
use data in degrees, minutes and seconds (DMS) - or just degrees and minutes if seconds are 
unavailable. The DMS format can be switched to decimal degrees by default or on a record by 
record basis using the LLUNIT field. In the default DMS mode, entries would be added to the 
LAT field as follows:

LAT NS Notes

12.0        N 12 degrees north

8.43  S 8 degrees and 43 minutes south

30.2312  N 30 degrees, 23 minutes and 12 seconds north

Note that a) the minutes and seconds are added directly after the decimal point and b) the field 
NS is edited to N or S. The equivalent fields LONG and EW are edited in the same way. Further 
information is provided under Documentation > mapping > Coordinate formats.
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Recording duplicate distribution

When adding data to RDE, you may have knowledge of the duplicate distribution of your 
specimens. These can be added as a comma separated string of herbarium codes to the DUPS 
field as in “FHO, K, MO, NY’. The A-Z order is not important. 

When you transfer an RDE file to BRAHMS, the system checks if all of your herbarium codes 
are in the herbarium list. If not, you will be prompted to add them.

Workshop 5 – editing synonymy and types

Introduction

This section provides guidance on how synonym and type links can be created either in your 
RDE files or within BRAHMS itself. Although these links can be created at the RDE file level and  
transferred into BRAHMS, most BRAHMS users tend to work up the synonym and type links 
inside BRAHMS itself.

Linking synonyms in your RDE file

Assuming both the accepted name and the synonym(s) have been added as separate records 
in your taxon RDE file, you can link the synonym(s) to the accepted name in the file. 

To make the links in the RDE file, the RDE file must include the numeric fields RDECODE and 
SYNOF.  These  fields  are  provided  by  default.  They  can  be  deleted  if  you  intend  to  edit  
synonymy after the transfer to BRAHMS.

• To link a name as a synonym of another name, the accepted name must be assigned a 
unique number in the RDECODE field and that same number must be added to the 
SYNOF field of the synonym(s).

In the above example, the species with RDECODE values 2 and 3 have been linked as synonyms to of  
the species with RDECODE value 1.

Linking synonyms within BRAHMS

• Select Taxa > View/edit species in database.
• Use the =>syn  toolbar option to make the current name a synonym of another name – 

you will be prompted to select this name.
• Use the syn<=  toolbar option to make another name a synonym of the current name.

You can also use the Nomc toolbar option to open the full nomenclature editing screen. 
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Editing names within BRAHMS using the nomenclature editing screen. This screen provides an immediate 
overview of the full nomenclature of a name and all related synonyms with options to manipulate synonym 
and type links. Use the +Syn and –Syn toolbars to create or remove synonym links. Note that a name 
may be edited to be a synonym of a name which is itself a synonym as in the case of Sabina  
polycarpos and others in this example.

Linking types in your specimen RDE file

• Click on the Type toolbar button. 
• A memo field called TYPEMEMO will be added to your RDE file and a screen opens 

where you can enter details about the type specimen (type category, where stored, 
typification species).

Linking types within BRAHMS

Types can be linked either from the main species or the main collection file.

• In the main species file (Taxa > View/edit species in database), use the Type toolbar 
option or open the main nomenclature screen using the Nomc toolbar.

• In the main collection file (Collections > View/edit collections in database), use the 
Spec toolbar option or open the specimen level edit screen.

In both cases, you will end up selecting a collection and then editing the specimen level details 
using the same screen as show below:
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Workshop 6 – preparing Species Plantarum outputs

Introduction

With your data safely stored in BRAHMS, it is possible to prepare different types of outputs. 
Although the focus in this workshop is on the preparation of reports for the Species Plantarum 
Project, by modifying the procedures explained here or using different ones, you can pick and 
choose those data you wish to report on and how you wish these data to be presented. For  
example,  although the printing of  specimen labels or loan forms is not  discussed here,  the 
reporting principals are broadly the same.

In this workshop, you will  prepare the central components of the Species Plantarum Project 
formatted output.

Querying data – making a taxon extract

As a first step in producing the outputs, you need to extract (query) your species list to make a  
selection of  the ‘accepted taxa’  to  include in  your  report.  You do not  need to  worry  about 
synonyms as these will be automatically gathered for you by the reporter. The querying of data  
is discussed in detail under  Documentation > Queries and extract files and examples are 
provided under Documentation > Training exercises > Data queries and extracts.

To start with, it is recommended that you concentrate on a single species. Later on, you can use  
exactly the same procedures to report on many taxa at the same time.

• Select Taxa > Extract/query data to open the main querying form. If you have already 
done a search, you should click on the Empty button (lower screen) to clear away the 
previous search results.

• Click on the Search taxa > Taxa button on the top left of the screen. From the list of 
options in the white drop-down box, choose the  Individual species option and then 
click on the Search / Add to search list button. This will open a species search form.

• Choose the individual species to work with. In the search string box and the bottom of 
this form, you can type in some genus letters + a space + some species name letters as 
in ‘ir gr’ to choose Irvingia grandifolia. If the number of genera in the database is large, 
you would need to enter more genus letters. The species search and select screen has 
other options to explore as you wish. When you have found the correct name in the list,  
click on the Select button on the species search screen.

• Finally, click on Search now to complete the query.

The above sequence of actions will create a taxon query file. Assuming the option Auto-open 
extract file after a search was ticked (default), the taxon query file will open automatically after 
your search. If  the query file does not open (tick the auto-open option when you next  do a 
query), then select the menu option Extracts > Taxa.

Report structure

The report  you will  now prepare will  use  a  BRAHMS Text  Reporting procedure.  This  will 
process data in your taxon extract file and generate your report in the following report sections

Accepted name This will include the monograph code, 
accepted name with author and place and 
date of publication.

Synonyms and types A list of synonyms organized in homotypic 
groups – together with the type specimen 
or notes about the type as with ‘original 
material’.

Illustration Note about illustration
Map Note about map
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Species description Text description as entered into the 
species memo field DESCRIP

Species distribution summary with 
TDWG codes

Distribution summary as entered into the 
species memo field TDWG

Cited specimens Specimen list formatted according to SPP 
requirements

Uses or other notes Uses or other notes as entered into the 
species memo field USES

Preparing to report

As a next  step,  we need to run some  Tools options in  the taxon extract  file  to add some 
formatted features which will be included in our report. Note that these options must be used 
after each new taxon query/extract.

a) Formatting the accepted name

• Select Tools > Formatting for reports > Format species name to FULLNAME. Click 
on the OK button to accept the default settings – or modify if necessary. This processes 
all species names in the taxon extract file and formats them into the extract file memo 
field FULLNAME. The formatting includes XML mark up for print features.

b) Formatting synonyms and types
 

• Select  Tools > Formatting for reports > Synonyms and types.  This assembles a 
formatted summary of  synonyms and type specimens to the extract  file  memo field 
TAXTREAT. The formatting includes XML mark up for print features.

c) Specimen citation

• Select  Tools  >  Collection  citation  lists.  Ensure  that  the  option  Fully  formatted 
citation list is selected on the screen. The SPP database has been provided with a 
pre-formatted specimen citation  list.  Click  on Prepare list  to  format  the list  into  the 
extract file memo field SPECLIST

Creating the report and transferring to a word processor

Having run the above mentioned Tools options,  you can now prepare the report  which will  
process all the taxa in your taxon extract file. In this example, there is only one species.

• Click on the Reports toolbar option 
• Select the Text/HTML reports option.  The option ‘SPP species text report’ should be 

the default but if not, select this report from the available list.
• Now click on the Generate a text report button .
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The report generation screen selected for Text/HTML reporting with the SPP species text report selected.

The report opens in an HTML file and can be copied using Ctrl+A followed by Ctrl+C and then 
pasted into a word processor document using Ctrl+V. If you use Microsoft Word, you can copy 
the report directly to Word using the  button on the reporting screen.

If you want to see how the report template has been set up or wish to make some alterations, 
select the Edit option on the report screen.

Preparing species distribution maps

Assuming you have installed  DIVA and the  base map files as explained in the  Prepare for 
mapping section and you have entered some specimens with LAT and LONG values, you can 
easily produce a species distribution map. Further help is provided under  Documentation > 
Mapping and Documentation > Training exercises > Mapping. 

The SPP template database has been provided with a few simple map configuration options 
already setup. You can adjust these by choosing the relevant Admin > Project configuration 
options.

The following example produces a map for a single species in the genus Leucaena. These data 
are  available  on  http://herbaria.plants.ox.ac.uk/BOL/samples/leucaena.aspx.  Replace  the 
Leucaena trichandra example with your own data as relevant.
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Create data file to map in BRAHMS

• Select Collections > Extract data. Using the option Taxa > Individual species, select 
Leucaena trichandra. 

• Open the extract file by selecting Extracts > Collections - assuming it is not auto-
opened after your extraction. 

Launch DIVA

• In the collection extract file, click on the Map toolbar button. The DIVA GIS option 
should be the default mapping software. 

• Make a note of the path and file name of the map data file you are about to create. Now 
click on the Map button to prepare the required map file and open DIVA. If DIVA does 
not open, check that your map configuration link is correct in Admin > Project 
configuration > File locations.

• Later on, you will be able to open DIVA and automatically open a base map, ready to 
add your specimen points to.

Add the base map layer(s) and zoom to area

• In DIVA, select Layer > Add layer and locate a .SHP file to plot. Assuming you 
downloaded the BRAHMS base maps as described earlier, choose the CNTRY.SHP.

• You can add additional layers if needed including the ADMIN.SHP file described earlier.
• To select a different area on your base map, use the Zoom toolbar and drag a 

rectangle on your map. This can be done at any stage. 
• To change the properties of a map layer such as the thickness of the map coastline, 

double-click the small map layer rectangle in the left DIVA margin and then double-
click the small rectangle on the resulting properties form and set the layer properties as 
prompted. Note that these actions can be carried out on any layer listed in the left 
margin. 

• For further notes on editing map layer properties, refer to the notes on  editing map 
areas and layers.

Add your map data points as a layer

• To plot your specimen data on the selected base map, select Data > Import points to 
Shape file > From dBASE (DBF). Click on the Input file option and locate the 
BRAHMS .DBF map file that you created above. 

• As prompted, select the X field LONG (for longitude) and the Y field LAT (for latitude). 
Note that when you create a map file, these lat/long fields are already in the correct 
decimal format and -ve for South and West. 
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• The Input file is the .DBF map file you created in BRAHMS. This file includes the (now) 
decimalized fields LONG and LAT which are selected for the X and Y map coordinates. 
You must choose an Output file .SHP file for DIVA to create from your BRAHMS file. 

• Use the Apply button to add the data points to the map. 

Data points properties

• After adding the data points file, double click the data file map layer in the left margin 
(it will be the top one) to open the properties form for that layer. 

• To change the colour, symbol and/or size of the points, double click on the point 
symbol and edit the settings as needed.

Editing the Properties of the data points layer. Numerous further options are available, especially using the  
Unique and  Class tabs on the Properties form – these are discussed in the BRAHMS documentation  
sections.

Final stages in Design mode

Note that in the bottom right corner of your map screen, there are 2 tabs Data and Design. So 
far you have been working in the Data screen. The final map will be produced in Design mode.

• Click on the Design tab and then click on the OK button in the left margin to redraw 
your map. 

At this stage, if  necessary, you can add a  map legend, scale bar and other map features. 
These features are discussed in the documentation and training exercises.
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To copy the completed map into Word or elsewhere, simply to copy the map to the clipboard in 

the Design screen using the Copy toolbar option  and then use Ctrl+V to paste the map into 
your document.

Simple species distribution map for Leucaena trichandra
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